Welcome to! Click one of these buttons to join in on the fun.

Blender, problems with lights, extensive problems, read within.

ZEUSeMONZEUSeMON0 Posts: 1Member
Hi all. So in my scene (model incomplete, I was adding lights to post to the work in progress page), there are a few suns, and I have been using spot lights for the lights on the ship. After a few minutes of the file being open, the lights stop working except for one sun.

Spot lights act as if a cone of the exact same size is sitting in front of the spot light. You can see in the screens, but it is as if a sliver of light is shining behind a cone or circle or whatever. If I turn shadows off on a specific light, that light will start working. In these screens I had gotten frustrated and deleted the entire project but for one light and one giant cube. I realized the problem when I first wanted to post to WIP three days ago and have been asking around since.


Area and point lights just don't work at all with shadows turned on. They do work when shadows are turned off.

All suns besides the first light in the scene act as if there is a 200m shroud around the camera. I say 200m because if i move the view render distance down, it matches with 200m. It is also centralized to the view, and only appears from that specific viewpoint. Again, reference the screenshot. In the second viewport you can see that Sun (no .001) works fine even within 200m of the viewpoint.


Idk what other information to put down, so I am just going to put everything down. Forgive me if I sound insane.

I obviously tried deleting everything else in the scene.

If I reload the project, open a new scene, load a different file completely, or open a whole new project, the problem persists into the new scene. However if I close blender completely I can get the lights back for a minute or two.

My computer cant handle recording the live render to show you, but a few minutes ago I loaded the project, had the lights, resized the viewport window (i think expanded it, and a few minutes later the same thing happened squishing it) and I watched the lights fade, like they were being dimmed, or the area was filling with fog.

The first time anything like this happened, I was playing with the world settings for the first time on a creature sculpt and I tried plugging a volume node into the world output to create a fog (Literally the first time I had ever seen the world material screen) and it immediately broke everything. That seems obvious now, it only sticks out to me that this is the first time the whole light thing occurred, as when I finally fixed the scene to be "normal" it was still super messed up, and making a new scene did nothing at all. The major difference there is the 200m "fog" also blocked emission lights from reaching the camera.

I have installed fresh copies of blender and upgraded to 4.0, but I really had NO idea what I was doing back then and I am afraid I may have changed a setting in blender that I had never seen before and have never seen again since. Especially since the problem doesn't seem to be linked to a specific project, and persists until I close the program and reopen it.

I am also afraid this is something to do with memory, because i would be crushed, I thought i finally found an art form I can actually afford to participate in.
Post edited by ZEUSeMON on


  • CoolhandCoolhand286 Mountain LairPosts: 1,295Member
    You should be able to tell via your OS if your memory is full, I doubt that is the issue but if so an additional stick of RAM for older machines is a pretty cheap upgrade.

    Download the portable/.zip ver of blender, the one you can use from a folder, ***without loading up any of your saves***try your experiment with the light in that version this should (presumably?) eliminate any settings you might have inadvertently altered.
  • backsteptbackstept2051 Posts: 921Member
    is it acting weird in both EEVEE and Cycles?
Sign In or Register to comment.