Welcome to! Click one of these buttons to join in on the fun.

Weird computer problems - HDD failure? Controller failure?

psychopsycho0 Posts: 0Member
edited August 2013 in General Discussion #1
Hey guys,

long time no see, and again i'm stepping by with a computer-issue...

i have some weird problems with my computer... it's a "hackintosh"... i guess, none of you has experience with hacks, but as this seems to be a hardware problem, this doesn't really matter...

First of all, my system:

Intel Core i5 3570k @ 4 Ghz
8GB Corsair XMS3 DDR3-1600 (2x4GB),Asus GeForce GT 640 2GB
1TB Western Digital Blue WD10EZEX
650 Watt LC-Power Silent Giant - Green Power Edition

It's a dual-boot system with both OSX 10.8.2 and Win7, each on a 500GB partition on the same HDD. A few days ago, while working with OSX, my system went slower and slower and finaly froze. I tried to reboot, it didn't work, so i started it in verbose-mode, where it stopped saying "disk0s2 i/o error" (and much more, i didn't note it).

After some research i came to the conclusion, that it might be a HDD error, but wasn't sure, because Win7 still started without any problems.

I bought 2 SSDs - 60GB Kingston SSD Now V300 - which i had planned anyway, tried several times to install 10.6.3 on one of them and it always stopped, saying that it the installation was unsucessful.

I then tried to install Windows on it and it didn't work neither until i set the AHCI-mode to IDE.

After installing Win7, i set it back to AHCI and suddenly, Windows didn't boot anymore.

Installing OSX with AHCI set to IDE failed, as i had expected.

Now it looked more like a Controller failure to me, but then i tried it with the other SSD and suddenly everthing worked fine! I got OSX 10.6.3 up and running, haven't updated to Mountain Lion yet.

This made me somewhat curious, so i plugged the old HDD in a SATA 3GB/S connector (it was in a SATA 6 GB/s before) and suddenly my old system boots again without any problems...

old HDD on SATA 6GB/s: OSX won't boot, Windows boots.
old HDD on SATA 3GB/S: everything's fine
SSD1 on SATA 6GB/s: can't install OSX, Installing Windows works only in IDE-mode
SSD2 on SATA 6GB/s: Installing OSX works fine, haven't tested Windows

Any idea what's wrong here? Do i have some weird HDD error which sometimes occurs and sometimes don't? But why doesn't one of the SSDs work, then?
Or is it a Controller Error? But why do some Disks work on the 6GB/s and some don't?
Post edited by psycho on


  • evil_genius_180evil_genius_1801854 Posts: 9,999Member
    Usually, if it's a bad drive or even just bad sectors on a drive, trying to use it at all doesn't work. However, you say it works when you switch ports and then your new drives only work on the other port as well, which leads me to believe it's the port that went bad. According to GIGABYTE's website, you have two 6GB/s ports, did you try either of the HDs in the other one? If it has a DVD-Rom or something on it, I would personally switch that to one of the 3GB/s ports, in order to keep the HD running at 6GB/s. (you use that more than the DVD-Rom)
  • Halo BuffHalo Buff171 Posts: 0Member
    Make certainthe drives are in fact compatible with that speed (you'd think they would but not always the case). Also try a different SATA cable, you may have a bad one or it is pinched causing connectivity loss. I've had a similar issue with IDE ribbons. Swiched the cord and that fixed it.
  • evil_genius_180evil_genius_1801854 Posts: 9,999Member
    One would think, if it was the cable, it would do it on both ports. But, I've seen stranger things, so it's at least worth looking into.
Sign In or Register to comment.