Greetings!

Welcome to Scifi-Meshes.com! Click one of these buttons to join in on the fun.

Greetings!

Welcome to the fancy new Scifi-Meshes.com! You old username and password should work. If not, get in touch with staff either here, on Facebook or on Discord.

For a quick summary on what's new, check out this thread.
You should also check out the Community Guidelines here.
You can check out most recent posts here or by clicking the handy links on the top menu or the sidebar.

You can dismiss this message by clicking the little X in the top right corner.

Sharp contrast on surfaces...

Chris2005Chris2005347 Posts: 2,975Member
For some reason, I'm getting sharp contrasts on surfaces, even though the geometry is perfect, it's quads, no weird issues, etc. but for some reason the light is causing sharp contrasts on round surfaces... I don't know why.

It happens with regular omni lights as well, in this scene I'm using a standard direct light.

11206889_914277455299188_4060480864002567599_o.jpg
Post edited by Chris2005 on
Tagged:

Posts

  • IRMLIRML232 Posts: 1,980Member
    you are worried about how your viewport looks?
  • Chris2005Chris2005347 Posts: 2,975Member
    IRML wrote: »
    you are worried about how your viewport looks?

    The renders are the same way. The viewport is almost exactly how the lighting looks in rendering, though, not quite as sharp as that.

    11090825_914571325269801_3750891348178731156_o.jpg
  • IRMLIRML232 Posts: 1,980Member
    so when did you notice this? have you changed any settings recently?
  • Chris2005Chris2005347 Posts: 2,975Member
    IRML wrote: »
    so when did you notice this? have you changed any settings recently?

    I've noticed it before, but I've never really gave it much thought until now.

    Aside from enabling gamma correction, no. This issue is present even without gamma correction. Even if I apply a regular material, no textures, etc. just a solid material, the light effects the same way. The geometry is fine, no weird geometry, etc. it's pretty much all quads.

    Ambient Occlusion renders render out fine, no sharp contrasts on curved surfaces. If I turn off all the lights and do a purely GI render, it looks fine as well.
  • IRMLIRML232 Posts: 1,980Member
    turn off spec for the key light and render that shot again
  • Chris2005Chris2005347 Posts: 2,975Member
    IRML wrote: »
    turn off spec for the key light and render that shot again

    With the specular turned off, the transition from light to dark is far smoother.

    11187232_914610361932564_4644814064501830621_o.jpg
  • IRMLIRML232 Posts: 1,980Member
    does this only happen when you render this model? or does it happen with other models too
  • Chris2005Chris2005347 Posts: 2,975Member
    IRML wrote: »
    does this only happen when you render this model? or does it happen with other models too

    This is the only model I can recall off hand that has this problem and only when using the specular textures... if I turn the specular off on each material, the light/shadow transition also looks fine.
  • IRMLIRML232 Posts: 1,980Member
    you should have mentioned that in the first post really, wouldn't have wasted as much time then

    check the shaders

    fin
  • Chris2005Chris2005347 Posts: 2,975Member
    IRML wrote: »
    you should have mentioned that in the first post really, wouldn't have wasted as much time then

    check the shaders

    fin

    I didn't know until I just checked, lol. I'm using standard Blinn materials.

    I got the specular hit softened up a bit, it's looking much better now. :)
  • japetusjapetus178 SeattlePosts: 782Member
    Um.....stupid question here, maybe I've been doing 3D too long to realize why it's happening, but why would turning off the spec in the light have improved the shadow harshness? Did the Contrast in the Advanced Effects get turned up? Probably some crappy max scanline fakery going on that caused it.
  • IRMLIRML232 Posts: 1,980Member
    japetus wrote: »
    Um.....stupid question here, maybe I've been doing 3D too long to realize why it's happening, but why would turning off the spec in the light have improved the shadow harshness? Did the Contrast in the Advanced Effects get turned up? Probably some crappy max scanline fakery going on that caused it.
    ordinarily it wouldn't

    I don't know what was wrong specifically with the specular lighting, but I could tell from the render that it was the spec hit looking sharp and not the diffuse, which is why I suggested to turn off the spec only to confirm this
Sign In or Register to comment.